INFORMATION COLLECTED
Summary zip to check any errors or events reported in engine.log during the timestamp of manually triggering the aggregate build from the UI; mostly, nothing will be reported.
TROUBLESHOOTING STEPS
To check if an existing cube has Active Aggregates
- Navigate to Aggregates
- Filter by project name --> cube name --> Select Active, then Search
ROOT CAUSE
No active aggregates were found. The existing aggregates might have been marked as deleted after a day by the aggregate maintainer as it cannot check the status due to the Hadoop cluster outage or AtScale service outage.
RESOLUTION
Please download the TDS (or thru Excel) for the cube and execute a few queries.
Check in the Design Center UI: If queries work and if they are against raw tables. After 2-3 runs if aggregates get generated. And after a few aggregates are generated, rebuild aggregates should work fine either from UI/Rest API/Hdfs File Location change